已解决 尝试修改语言时报错

  • 欢迎 游客 您的光临,下载之前请先阅读 积分规则(暂行) 。任何技术问题请在论坛提问,本站定制插件、模板主题售前、售后问题请联系QQ:5916171
UID
153
注册
2018/07/14
消息
28
反馈评分
3
黄金
35.0G
    Windows 10 Chrome 76.0.3809.100
  • #1
修改语言的Error
代码:
ParseError: syntax error, unexpected 'Fn' (T_FN), expecting identifier (T_STRING) or '{' in src/XF/Template/Compiler.php at line 8
Composer\Autoload\includeFile() in src/vendor/composer/ClassLoader.php at line 322
Composer\Autoload\ClassLoader->loadClass()
spl_autoload_call() in src/XF/App.php at line 1292
XF\App->XF\{closure}() in src/XF/Container.php at line 28
XF\Container->offsetGet() in src/XF/App.php at line 2970
XF\App->templateCompiler() in src/XF/Service/Template/Compile.php at line 11
XF\Service\Template\Compile->recompile() in src/XF/Service/Phrase/Compile.php at line 71
XF\Service\Phrase\Compile->recompileIncludeContent() in src/XF/Entity/Phrase.php at line 171
XF\Entity\Phrase->_postSave() in src/XF/Mvc/Entity/Entity.php at line 1208
XF\Mvc\Entity\Entity->save() in src/XF/Mvc/FormAction.php at line 69
XF\Mvc\FormAction->XF\Mvc\{closure}() in src/XF/Mvc/FormAction.php at line 187
XF\Mvc\FormAction->run() in src/XF/Admin/Controller/Phrase.php at line 128
XF\Admin\Controller\Phrase->actionSave() in src/XF/Mvc/Dispatcher.php at line 321
XF\Mvc\Dispatcher->dispatchClass() in src/XF/Mvc/Dispatcher.php at line 244
XF\Mvc\Dispatcher->dispatchFromMatch() in src/XF/Mvc/Dispatcher.php at line 100
XF\Mvc\Dispatcher->dispatchLoop() in src/XF/Mvc/Dispatcher.php at line 50
XF\Mvc\Dispatcher->run() in src/XF/App.php at line 2178
XF\App->run() in src/XF.php at line 390
XF::runApp() in admin.php at line 13
 
最后编辑:

小关_

打酱油的路过~~
管理成员
UID
255
注册
2019/01/25
消息
449
解决方案
6
反馈评分
1,393
黄金
4,494.0G
    Android Chrome Mobile 74.0.3729.186
  • #2
您好,您具体是在哪里修改的语言呢
 
UID
153
注册
2018/07/14
消息
28
反馈评分
3
黄金
35.0G
    Windows 10 Chrome 76.0.3809.100
  • #3
您好,您具体是在哪里修改的语言呢

我发现,升级7.4就会导致外观的语言、模板修改时出现此错误

降回7.2才能修改
 

小关_

打酱油的路过~~
管理成员
UID
255
注册
2019/01/25
消息
449
解决方案
6
反馈评分
1,393
黄金
4,494.0G
    Windows 10 Chrome 79.0.3945.79
  • #4
我发现,升级7.4就会导致外观的语言、模板修改时出现此错误

降回7.2才能修改
那就降回7.2吧